Linux内核TCP SACK机制远程拒绝服务漏洞修复

boke112导航 122
OUIMS博客广告

2019 年 6 月 18 日,国外某安全研究组织披露 Linux 内核存在 TCP “SACK PANIC”远程拒绝服务漏洞(漏洞编号:CVE-2019-11477,CVE-2019-11478,CVE-2019-11479),攻击者可利用该漏洞远程攻击目标服务器,导致系统崩溃或无法提供服务。为避免服务器被攻击受影响,建议大家及时开展安全自查,如在受影响范围,请及时进行更新修复,避免被外部攻击者入侵。

Linux内核TCP SACK机制远程拒绝服务漏洞修复-第1张图片-OUIMS博客

漏洞描述

Linux 内核 2.6.29 及之后版本在处理 TCP SACK 机制时存在缺陷,导致整数溢出漏洞,攻击者可以构造特定的 SACK 包,远程触发 Linux 服务器内核模块溢出漏洞,实现远程拒绝服务攻击。

阿里云

1、漏洞评级

  • CVE-2019-11477 高危

  • CVE-2019-11478 中危

  • CVE-2019-11479 中危

2、安全修复建议

注:以下任意一种修复方式都有可能造成业务不可用,请注意建立快照备份。

2.1 禁用 SACK 机制功能,执行如下命令:

echo 0 > /proc/sys/net/ipv4/tcp_sacksysctl -w net.ipv4.tcp_sack=0

2.2 升级 Linux 安全补丁(需要重启服务器)

  • Ubuntu 系列:apt-get update && sudo apt-get install linux-image-generic

  • Centos 系列:yum update kernel

  • 其他 Linux 补丁可参考:https://github.com/Netflix/security-bulletins/tree/master/advisories/third-party/2019-001

以上内容来自@阿里云

腾讯云

1、风险等级:高风险

2、漏洞风险

远程发送特殊构造的攻击包,导致目标 Linux 或 FreeBSD 服务器崩溃或服务不可用。

3、影响版本

目前已知受影响版本如下:

  • FreeBSD 12(使用到 RACK TCP 协议栈)

  • CentOS 5(Redhat 官方已停止支持,不再提供补丁)

  • CentOS 6

  • CentOS 7

  • Ubuntu 18.04 LTS

  • Ubuntu 16.04 LTS

  • Ubuntu 19.04

  • Ubuntu 18.10

4、安全版本

各大 Linux 发行厂商已发布内核修复补丁,详细内核修复版本如下:

  • CentOS 6 :6.32-754.15.3

  • CentOS 7 :10.0-957.21.3

  • Ubuntu 18.04 LTS:15.0-52.56

  • Ubuntu 16.04 LTS:4.0-151.178

  • FreeBSD:腾讯云官方提供的 FreeBSD 镜像默认不受该漏洞影响,请放心使用。

5、修复建议

请参照上述【安全版本】升级您的 Linux 服务器内核,参考操作如下:

5.1 推荐方案:【CentOS 6/7 系列用户】

1)yum clean all && yum makecache,进行软件源更新;

2)yum update kernel  -y,更新当前内核版本;

3)reboot,更新后重启系统生效;

4)uname -a,检查当前版本是否为上述【安全版本】,如果是,则说明修复成功。

5.2 推荐方案:【Ubuntu 16.04/18.04 LTS 系列用户】

1)sudo apt-get update && sudo apt-get install linux-image-generic,进行软件源更新并安装最新内核版本;

2)sudo reboot,更新后重启系统生效;

3)uname -a,检查当前版本是否为【安全版本】,如果是,则说明修复成功。

5.3 临时缓解方案

如用户不方便重启进行内核补丁更新,可选择如下方式禁用内核 SACK 配置防范漏洞利用,运行如下命令即可:

1)echo 'net.ipv4.tcp_sack = 0' >> /etc/sysctl.conf ,禁用 SACK 配置;

2)sysctl -p ,重载配置,使其生效。

标签: 最新资讯 站长资讯 服务器教程

OUIMS博客广告

发表评论 (已有0条评论)

还木有评论哦,快来抢沙发吧~